Α.Ε.Π.Π. : Δομή Επανάληψης ΟΣΟ

30

Settings
Please wait...
Α.Ε.Π.Π. : Δομή Επανάληψης ΟΣΟ

Ένα τεστ για την δομή επανάληψης ΟΣΟ που διδάσκεται στο μάθημα Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον της Γ' Λυκείου.


Questions and Answers
  • 1. 
    Οι εντολές που περικλείονται σε μία εντολή ΟΣΟ εκτελούνται όσο η συνθήκη είναι αληθής.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 2. 
    Η επανάληψη ΟΣΟ ελέγχεται από μία λογική έκφραση στο τέλος κάθε επανάληψης.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 3. 
    Σε μία εντολή επανάληψης ΟΣΟ η συνθήκη ελέγχεται σε κάθε επανάληψη.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 4. 
    Αν η συνθήκη συνέχειας σε μία εντολή επανάληψης ΟΣΟ είναι αρχικά ΨΕΥΔΗΣ η επανάληψη θα εκτελεστεί μία μόνο φορά.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 5. 
    Σε μία εντολή επανάληψης ΟΣΟ που εκτελείται επ’ άπειρον η συνθήκη συνέχειας είναι αρχικά ΨΕΥΔΗΣ και στην συνέχεια γίνεται ΑΛΗΘΗΣ.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 6. 
    Τι θα εμφανίσει το παρακάτω κομμάτι κώδικα στην οθόνη;      Ι <-- 2      ΟΣΟ ( Ι < 6 ) ΕΠΑΝΑΛΑΒΕ         Ι <-- Ι + 2         ΓΡΑΨΕ Ι      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    • A. 

      2 3 4 5

    • B. 

      4 5

    • C. 

      2 4 6

    • D. 

      4 6

  • 7. 
    Τι θα εμφανίσει ο παρακάτω κώδικας στην οθόνη;      Ι <-- 10      ΟΣΟ ( Ι >= 4 ) ΕΠΑΝΑΛΑΒΕ         ΓΡΑΨΕ Ι         Ι <-- Ι - 3      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    • A. 

      10 9 8 7 6 5 4

    • B. 

      10 8 6 4

    • C. 

      10 7 4

    • D. 

      10 7

  • 8. 
    Με την εντολή επανάληψης ΟΣΟ μπορούν να εκφραστούν όλες οι επαναλήψεις.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 9. 
    Στην εντολή επανάληψης ΟΣΟ δεν απαιτείται να υπάρχει εντολή που να αλλάζει την τιμή της μεταβλητής που ελέγχεται με την συνθήκη.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 10. 
    Η επιλογή μίας αυθαίρετης τιμής για τον τερματισμό μίας επαναληπτικής διαδικασίας δεν είναι συνηθισμένη στον προγραμματισμό.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 11. 
    Δεν επιτρέπεται να υπάρχει μία δομή επιλογής ΕΠΙΛΕΞΕ μέσα σε μία δομή επανάληψης ΟΣΟ.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 12. 
    Σε μία εντολή επανάληψης ΟΣΟ η αρχικοποίηση των μεταβλητών που εμφανίζονται στην συνθήκη πρέπει να γίνεται στην αρχή κάθε επανάληψης.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 13. 
    Πως θα συμπληρώνατε τα κενά στο παρακάτω κομμάτι κώδικα έτσι ώστε να υπολογίζεται το άθροισμα όλων των ακεραίων αριθμών από το 17 έως το 26.      Α <-- __________      Μ <-- 16      ΟΣΟ Μ < _________ ΕΠΑΝΑΛΑΒΕ         Α <-- Α + Μ + 1         Μ <-- Μ + 1        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    • A. 

      0 26

    • B. 

      16 26

    • C. 

      16 27

    • D. 

      0 27

  • 14. 
    Έστω το παρακάτω κομμάτι κώδικα:      Α <-- 0      Θ <-- 0      Ι <-- 1      ΟΣΟ Ι <= 10 ΕΠΑΝΑΛΑΒΕ         ΔΙΑΒΑΣΕ Χ         ΑΝ Χ >= 0 ΤΟΤΕ            Θ <-- Θ + 1         ΑΛΛΙΩΣ            Α <-- Α + 1         ΤΕΛΟΣ_ΑΝ         Ι <-- Ι + 1        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣΗ τιμή που αποθηκεύεται στην μεταβλητή Θ είναι:
    • A. 

      το πλήθος των θετικών αριθμών

    • B. 

      το άθροισμα των θετικών αριθμών

    • C. 

      το πλήθος των αρνητικών αριθμών

    • D. 

      το άθροισμα των αρνητικών αριθμών

  • 15. 
    Στην εντολή επανάληψης ΟΣΟ η μεταβλητή που μετράει Ν επαναλήψεις πρέπει να παίρνει πάντα τις τιμές 1, 2, 3, 4, … Ν.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 16. 
    Η μεταβλητή μετρητής σε μία δομή ΟΣΟ πρέπει πάντα να αρχικοποιείται με 1.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 17. 
    Η συνθήκη συνέχειας σε μία δομή επανάληψης ΟΣΟ δεν μπορεί να ελέγχει δύο μεταβλητές.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 18. 
    Ένα τμήμα αλγορίθμου που εκτελείται επαναληπτικά αποκαλείται βρόχος (Εξετάσεις 2007).
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 19. 
    Στην εντολή επανάληψης ΟΣΟ … ΕΠΑΝΑΛΑΒΕ δεν γνωρίζουμε εκ των προτέρων το πλήθος των επαναλήψεων.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 20. 
    Οι εντολές που βρίσκονται σε μια επανάληψη ΟΣΟ, εκτελούνται τουλάχιστον μία φορά (Εξετάσεις 2005, 2007).
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 21. 
    Δεν μπορεί να χρησιμοποιηθεί η ίδια μεταβλητή ως μετρητής δύο ή περισσότερων βρόχων που ο ένας βρίσκεται στο εσωτερικό του άλλου (Εξετάσεις 2006).
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 22. 
    Σε μία δομή επανάληψης ΟΣΟ όσο η συνθήκη συνέχειας είναι ψευδής συνεχίζεται η επαναληπτική διαδικασία.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 23. 
    Σε μία δομή επανάληψης ΟΣΟ που ελέγχεται από μετρητή πρέπει ο μετρητής να αρχικοποιείται στην αρχή κάθε επανάληψης.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 24. 
    Μία δομή επανάληψης που βρίσκεται μέσα σε μία άλλη δομή επανάληψης ονομάζεται κυκλική επανάληψη.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 25. 
    Μία δομή επανάληψης δεν μπορεί να βρίσκεται μέσα σε μία δομή επιλογής.
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 26. 
    Ποια δομή ΟΣΟ εκτελείται για πάντα αν η μεταβλητή Κ έχει αρχική τιμή 5;
    • A. 

      ΟΣΟ ( Κ

    • B. 

      ΟΣΟ ( Κ >= 0 ) Κ

    • C. 

      ΟΣΟ ( Κ

    • D. 

      ΟΣΟ ( Κ >= 0 ) Κ

  • 27. 
    Τι θα εμφανίσει ο παρακάτω κώδικας στην οθόνη;      Α <-- 1      Β <-- 15      ΟΣΟ ( Α < 15 ) ΕΠΑΝΑΛΑΒΕ         Β <-- Β - 1         Α <-- Α + 1      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ      ΓΡΑΨΕ Β, Α
    • A. 

      1 15

    • B. 

      1 14

    • C. 

      0 14

    • D. 

      0 15

  • 28. 
    Ποια τιμή της μεταβλητής Α θα εμφανίσει ακριβώς 10 φορές την λέξη «ΛΥΚΕΙΟ» στην οθόνη;      Ι <-- 0      ΟΣΟ ( Ι < Α ) ΕΠΑΝΑΛΑΒΕ         ΓΡΑΨΕ "ΛΥΚΕΙΟ"         Ι <-- Ι + 2      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    • A. 

      0

    • B. 

      9

    • C. 

      18

    • D. 

      20

  • 29. 
    Η εντολή επανάληψης       Ι <-- 1      ΟΣΟ ( Ι <= 100 ) ΕΠΑΝΑΛΑΒΕ         Κ <-- Κ + 1      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣεκτελείται επ' άπειρον;
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ

  • 30. 
    Η εντολή επανάληψης       Ι <-- 1      ΟΣΟ ( Ι <= 100 Ή ΑΛΗΘΗΣ ) ΕΠΑΝΑΛΑΒΕ         Ι <-- Ι + 1      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣεκτελείται επ' άπειρον;
    • A. 

      ΣΩΣΤΟ

    • B. 

      ΛΑΘΟΣ